Deliverable D1

User Manual

CheckBMG

<table>
<thead>
<tr>
<th>Name</th>
<th>Date</th>
<th>Signature</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prepared by</td>
<td>Benoît Thiébault</td>
<td>14/12/2010</td>
</tr>
<tr>
<td>Verified by</td>
<td>Jérémie Turbet</td>
<td>15/12/2010</td>
</tr>
<tr>
<td>Approved by</td>
<td>Julien Forest</td>
<td>16/12/2010</td>
</tr>
</tbody>
</table>

Reference: IFR_BMGV3_D1B_Check_User_Manual  Version: 3  Revision: 0
Status: Final  Date: 16/12/2010

This document is the property of Artenum. It cannot be used, copied or distributed without prior written approval.
Presentation

The objective of this document is to provide the user of CheckBMG the relevant information to understand how to install, launch and use the application.

Technical content summary

This document is divided in two main parts:

- The prerequisites detail the hardware and software requirements to run the application, explains how to install and launch the application.
- The second part explains how to use the application and details its main functions.

Diffusion

<table>
<thead>
<tr>
<th>Name</th>
<th>Organisation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Julien Forest</td>
<td>Artenum</td>
</tr>
<tr>
<td>Benoît Thiébaut</td>
<td></td>
</tr>
<tr>
<td>Jérémie Turbet</td>
<td></td>
</tr>
<tr>
<td>Sébastien Theetten</td>
<td>IFREMER</td>
</tr>
<tr>
<td>Fabrice Lecornu</td>
<td></td>
</tr>
<tr>
<td>Jean-François Le Roux</td>
<td></td>
</tr>
<tr>
<td>Franck Dumas</td>
<td></td>
</tr>
<tr>
<td>Pascal Douillet</td>
<td></td>
</tr>
</tbody>
</table>

Changes

<table>
<thead>
<tr>
<th>Version</th>
<th>Revision</th>
<th>Date</th>
<th>Auteur / Observation</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>15/04/2009</td>
<td>Benoît Thiébault / Document creation</td>
</tr>
<tr>
<td>1</td>
<td>2</td>
<td>20/10/2009</td>
<td>Benoît Thiébault / Update to take into account version 2.0 Alpha</td>
</tr>
<tr>
<td>1</td>
<td>3</td>
<td>16/12/2009</td>
<td>Benoît Thiébault / Update to take into account version 2.0 Bêta</td>
</tr>
<tr>
<td>2</td>
<td>0</td>
<td>24/02/2010</td>
<td>Benoît Thiébault / Update to take into account version 2.0</td>
</tr>
<tr>
<td>3</td>
<td>0</td>
<td>16/12/2010</td>
<td>Benoît Thiébault / Update to take into account version 3.0.0-alpha</td>
</tr>
</tbody>
</table>
# Table of contents

1. INTRODUCTION ........................................................................................................... 5
   1.1. CheckBMG and BMGTools .................................................................................. 5
   1.2. Applicable documents ...................................................................................... 5
   1.3. Acronyms, abbreviations and definitions ......................................................... 5

2. PREREQUISITES ............................................................................................................. 6
   2.1. Configuration ....................................................................................................... 6
      2.1.1. Hardware requirements ............................................................................... 6
      2.1.2. Software requirements ............................................................................... 6
   2.2. Installation .......................................................................................................... 6
   2.3. Running the application .................................................................................... 6

3. USING THE APPLICATION ............................................................................................ 7
   3.1. User interface ...................................................................................................... 7
      3.1.1. Overview ................................................................................................... 7
      3.1.2. Menu bar .................................................................................................. 7
      3.1.3. Map viewer .............................................................................................. 8
      3.1.4. Layers view .............................................................................................. 10
      3.1.5. Grid display modes and depth values ....................................................... 11
      3.1.6. Status bar ................................................................................................. 15
   3.1. Opening an existing file ....................................................................................... 15
   3.2. Saving the grid file ............................................................................................. 17
   3.3. Closing the grid file ........................................................................................... 17
   3.4. Setting up the preferences .................................................................................. 17
   3.5. Exiting the application ....................................................................................... 21
   3.6. Manipulating the map ....................................................................................... 21
   3.7. Editing grid points ............................................................................................. 21
   3.8. Editing river positions ....................................................................................... 23
   3.9. Viewing the grid in 3D ...................................................................................... 24
   3.10. Undoing an action ............................................................................................. 24

ANNEX A  BATHYMETRIC GRID FILE .............................................................................. 26

ANNEX B  COASTLINE FILE .LINE ................................................................................ 29

---

This document is the property of Artenum. It cannot be used, copied or distributed without prior written approval.
ANNEX C  SOUNDINGS FILE .SDG.........................................................32

ANNEX D  RIVERS FILE .RIVER.........................................................34

ANNEX E  COLOUR BAR FILE FORMAT.............................................35
1. Introduction

1.1. CheckBMG and BMGTools

The BMGTools, created by IFREMER, are a set of pre-processing tools that help you create, check and modify bathymetric grids.

CheckBMG is a part of the BMGTools. Its purpose is to help you to visualise grids created with the MARS code or with other applications and to allow you to check the relevance of the interpolation. If necessary, you can modify the grid to manually correct algorithm errors.

The present document is the user manual of CheckBMG.

1.2. Applicable documents


1.3. Acronyms, abbreviations and definitions

- TBC: to be confirmed
- TBD: to be determined
2. Prerequisites

2.1. Configuration

2.1.1. Hardware requirements

The minimal hardware configuration to properly run the BMG Tools is:

- Intel/AMD x86 32/64bit processor, with a frequency higher than 1.7GHz (Intel Core 2 Duo T7700 at 2.4 GHz recommended)
- 1Gb of RAM (2Gb recommended, especially for large grids)
- Graphic card with more than 128Mb of video memory (NVIDIA Quadro FX 570M or equivalent recommended)
- Screen resolution of 1024x768 pixels (1280x1024 resolution recommended)
- 100Mb of free space on the hard drive

2.1.2. Software requirements

The BMG Tools have been tested to work under Windows XP SP3 and Linux Fedora Core 8. It requires SUN Java 6 or higher installed (cf. http://www.java.com for the latest version download).

2.2. Installation

The application should be provided in a compressed archive (.zip or .gz for instance). Simply uncompress the archive to the desired location of your hard drive.

The folder obtained after decompression is illustrated on Figure 1.

2.3. Running the application

In the check folder, there are two executable files. Under Windows, these are:

- **CheckBMG.bat**, a DOS batch command that can be launched by double-clicking it;
- **ProfileCheckBMG.bat**, a DOS batch command that can be launched by double-clicking it;

On Linux machines the executable files are:

- **CheckBMG.sh**, the shell script command that can be executed via command line;
- **ProfileCheckBMG.sh**, the shell script command that can be executed via command line;

The profile command is present for test purpose only. It logs in the terminal the different times to execute some key functions (like refreshing the user interface).

For users who want to create grid with the tools, the CheckBMG command is sufficient.
3. Using the application

3.1. User interface

3.1.1. Overview

When the application is first opened, the window displayed in Figure 2 appears on the screen. It is divided in 5 main parts:

1) The menu bar gives you access to some of the application main functions. It is composed of five menu items, *File, Views, History, Tools* and *Help* and of a tool bar containing buttons for actions that are frequently used.

2) The map tool bar allows you to select the different tools available for you to interact with the data and its representation. When you perform a copy/paste action, the copied value appears on the right part of this tool bar.

3) The layers view shows the layers that have been loaded by the user. Layers on top of this layer view are drawn on top in the map view.

4) The map view allows you to interact with the map representation of the data.

5) The status bar gives you information about the projection system and the mouse cursor position on the map.

![Figure 2: Interface overview](image)

3.1.2. Menu bar

The menu bar (cf. Figure 3) contains four menu items and a tool bar:
The File menu contains the application main operations:

- **Open grid file** to open an existing grid file and the associated coastlines and soundings
- **Close grid file** to close the current grid file
- **Save grid file** to save the current grid file
- **Save grid as...** to save the current grid file under a different name
- **Export** to save the map either in PNG or EPS format. Beware that the EPS format is a vector representation of the image. This means that every graphic element displayed on the screen is saved as a vector object in the file. This has the advantage of providing a file that can be indefinitely zoomed in without loss of quality. The counterpart is that for maps containing a lot of elements (such as soundings points for instance), the EPS file can quickly become huge and hard to manipulate. In that case, prefer the use of the PNG bitmap format.
- **Preferences** to access the application settings
- **Quit** to exit the application

The Views menu contains the list of views that the user can open and close.

The History menu contains the list of your last actions that can be undone.

The Tools menu contains extra functions, like the 3D view of the map. This action can only be performed if VTK is properly installed (i.e. on target platforms) and if a grid is loaded.

The Help menu gives access to the About dialog, displaying general information about the application.

The tool bar provides shortcuts for the following menu functions:

- **Open grid file**
- **Save grid file**
- **Preferences**

Some of the menu items and tool bar buttons are deactivated by default. They activate automatically when necessary.

- **Figure 3: Menu bar**

### 3.1.3. Map viewer

The map viewer (cf. Figure 5) is composed of the map, the colour bar scale and the tool bar:

- The map itself displays loaded information, such as grids, coastlines, soundings, etc. In order to keep the rendering quick and efficient, a Level Of Detail (LOD) algorithm, which only displays a part of the real data, is automatically applied when the data is seen from far away. When this algorithm is activated, a LOD icon is displayed on the top left corner of the map (cf.
Figure 4). The level of the algorithm is also displayed. The higher the level, the more data is hidden.

⚠ **LOD: 3**

*Figure 4: Level Of Detail warning icon and algorithm level*

- The tool bar allows you to interact with the map. It is composed of one isolated button on the left and of a toggle buttons bar. The isolated button at the left resets the view to the initial map zoom when pressed. The toggle buttons bar contains several buttons. One and only one button of this tool bar is always selected. Depending on which button is selected, the main mouse action on the map have different effects (the main action can attributed to any of the mouse buttons, as seen in 3.4):

  - The **Move** button, on the left, lets you move the map
  - The **Zoom in** button allows you to zoom in the map by either clicking a place on the map or selecting a zoom zone with a mouse drag and drop action.
  - The **Zoom out** button allows you to zoom out the map by either clicking a place on the map or selecting a zoom zone with a mouse drag and drop action.
  - The **Edit grid points** button offers the possibility to edit the grid points one by one, sequentially, by selecting a rectangular or a polygonal zone (cf. 3.7 for more details).
  - The **Save grid points button** allows you to save in a text file the grid points that have been selected either sequentially or by selecting a rectangular or a polygonal zone.

Whatever the selected tool, you can zoom in or out the map with the mouse wheel.

- The **Copied value** text field shows the depth value (in meters) that is stored in memory and will be applied if you perform a Paste action on the grid.

- The colour bar scale is displayed at the bottom of the map and shows you the colour / depth value correspondence. It can be edited by clicking the **Edit color bar** button, similarly as in the Preferences panel (cf. 3.4). The only difference is the **Apply changes** button that directly applies the colour bar modifications to the data displayed. The edition dialog is not modal, which means you can still interact with the map even if this dialog is not closed.
3.1.4. Layers view

The layers view illustrated on Figure 6, show all the layers currently loaded in the application and shown on the map viewer. The check box at the right side of each layer can be used to display or hide the corresponding layer.

The “+” and “-” buttons at the top right can be used to dynamically add or remove layers.

Figure 5: Map viewer

Figure 6: Layers view
3.1.5. Grid display modes and depth values

There are two grid display modes in CheckBMG: $H_x/H_y$ mode and $H_0$ mode.

When the $H_x/H_y$ mode is selected (cf. Figure 7), only the cell bounds are displayed on the map. The vertical segments correspond to $H_x$ while the horizontal segments correspond to $H_y$. Each segment has a different depth and can be modified independently.

![Figure 7: Map in $H_x/H_y$ mode](image)

When the $H_0$ mode is selected (cf. Figure 8), the cells are fully painted, representing the $H_0$ depth.
Figure 8: Map in $H_0$ mode

Whatever the display mode, you can see the exact depth value of the displayed grid elements by selecting the Grid text values item in the Layers view as illustrated on Figure 9 and Figure 10.
**Figure 9:** Grid depth values in $H_x/H_y$ display mode

**Figure 10:** Grid depth values in $H_0$ display mode
You can as well visualise soundings depth values by selecting the **Soundings text values** item in the **Layers view** as illustrated on **Figure 11**. The soundings text values are displayed as a 45 degrees rotated text on the map so that they are not misinterpreted as grid text values. This rotation angle can be configured, as explained in 3.4.

![Figure 11: Soundings depth values](image)

When selecting the **Isobaths values** in the **Layers view**, the associated depth is drawn along the corresponding isobath line, as shown on **Figure 12**.
3.1.6. Status bar

The status bar (cf. Figure 13) displays two kinds of information:

- On the left, the projection system in which the data is drawn on the map is displayed.
- On the right, the mouse cursor coordinates on the map are given either in geographic coordinates (degrees), in projected coordinates (meters) or in grid indexes. The depth of the nearest grid point element is also displayed here.

Figure 12: Isobaths depth values

3.1. Opening an existing file

To open an existing grid file, you have to click the File>Open grid file menu item or to select the Open grid file shortcut button.

You will then be asked to select the files to load (cf. Figure 14).
Figure 14: Open MARS grid file dialog

By default, the grid file to provide is a NetCDF file generated by MARS. This file format is described in Annex A. If you want to proceed using the software, this is the only file you can provide. The geodetic and projection systems are automatically chosen by the application if they are indicated in the grid file. You can choose a different projection system in the drop down menu. If the geodetic system is not described in the grid file, you have to select it in the drop down menu.

If you wish to load files created with NEMO (http://www.nemo-ocean.eu/), you can choose the NEMO file format is the drop down menu, as illustrated in Figure 15.

Figure 15: Open NEMO grid files (coordinates and bathymetry)
In this case, you have to provide two different files: a coordinates file, then the corresponding bathymetry file. When viewing a NEMO grid file, only the $H_0$ display mode is available.

There is then a set of optional files that you can provide if you wish to visualise other data.

You can provide a “coastlines file”, containing coastlines and/or isobaths data. This file can be provided either in the .line format, described in Annex B or in the Shapefile format. The Shapefile format is however only partially supported for files coming from the SHOM or SEXTANT database.

You can provide as well a soundings file, whose format is described in Annex C. This file is optional.

Finally, you can provide an optional river file, whose format is described in Annex D.

To validate your choice, you have to click the OK button. The selected files are then loaded and displayed on the map. As the soundings file can be very heavy (more than 2 million soundings for instance), it is not displayed on the map by default to accelerate the map drawing process. The file is however loaded in background. As soon as it is fully loaded and ready to be displayed, the two corresponding items are added in the Layers view (one item to display the soundings, another to display the text values).

### 3.2. Saving the grid file

If you have modified the grid, you can choose to save the file by selecting the File>Save grid file menu item or by clicking the save grid file shortcut button.

You can only save the grid file when a modification has been made. At anytime, however, you can choose the File>Save grid as... menu item to save the grid file with a different name or at a different location.

### 3.3. Closing the grid file

To close an opened grid file, you have to select the File>Close grid file menu item.

If the grid file has been modified, you will be proposed to save the grid file first.

### 3.4. Setting up the preferences

To edit the application preferences, you can select the File>Preferences... menu item or to click the preferences shortcut button.

The preferences window is separated in two tabs:

- The General tab (cf. Figure 16) contains preferences common throughout the BMGTools. You can here change the interface language (requires to restart the application to be effective), change the different coastline file elements colour and set the colour gradient associated with the isobaths depth (see below for more details).
If you want to edit one of the colour bars available, you have to select the colour bar and click the **Edit color bar** button that shows the **Edit color bar** window (cf. **Figure 17**). There are three colour bars provided by default. These default colour bar cannot be deleted or overridden, so if you wish to modify them, you will have to change their name in the **Edit color bar** window. You can also import an existing colour bar by using the **Load...** button. The file format for colour bar files is described in Annex E.

In the **Edit color bar** window, you can add new colours in the colour bar or delete existing ones.

To add a new colour, click the coloured button next to the **Color** text. A dialog will let you choose the colour you want to add. After choosing a colour, input a colour position in the colour bar. The colour bar contains a configurable number of colours (say $nbColours$). The position of the new colour has to be between 1 and $nbColours - 2$ (as the starting and ending colours are at positions 0 and $nbColours - 1$). Then click the **Add color** button.

To remove a colour, simply select the thumb representing it and click the **Delete color** button.

You can also change colours position in the gradient by dragging the colour’s thumb, change the total number of colours in the colour bar and choose an automatic range (that will be adapted to the data scalar range when data is loaded) or force a given one.
The CheckBMG preferences tab (cf. Figure 18) contains preferences specific to this application. You can choose the colour of the selected grid elements, of the elements with ground values, the font characteristics of the text values and other graphic elements settings. This is also where you can configure the buttons of your mouse and attribute to each of them a specific action. There are four configurable actions available:

- **Main action**: this is the action that is performed according to the selected button in the tool bar (to move the map, zoom in or out, edit the grid points, etc.).
- **Copy**: allows you to copy the value of the nearest grid element
- **Paste**: pastes the copied value (displayed in the tool bar) to the nearest grid point.
- **Contextual menu**: shows a contextual menu (cf. Figure 19) allowing you to copy, paste a grid element.

You can go back to default settings by pressing the default button.

**Figure 17: Edit gradient window**
Figure 18: CheckBMG preferences

Figure 19: Contextual menu
3.5. Exiting the application

To close the application, you have to select the File>Quit menu.

If the grid file has been modified, you will be proposed to save the grid file.

3.6. Manipulating the map

The navigation map tool bar (cf. Figure 20) allows you to manipulate the map. The initial zoom button on the left of the tool bar resets the zoom level to the initial one when pressed.

The Move button lets you move the map.

The Zoom in button allows you to zoom in the map by either clicking a place on the map or selecting a zoom zone with a mouse drag and drop action on the map.

The Zoom out button allows you to zoom out the map by either clicking a place on the map or selecting a zoom zone with a mouse drag and drop action on the map.

You can as well use the mouse wheel to zoom in or out in the map.

![Figure 20: Navigation map tool bar](image)

3.7. Editing grid points

The Edit grid points button (cf. Figure 21) allows you to edit grid points.

![Figure 21: New grid button](image)

Once selected, you can choose the edition mode in a drop-down menu:

- **Single point** mode lets you modify the grid elements one by one;

- In **Sequential** mode, you can select several grid elements in a row, then press **Return** to change the values (cf. Figure 22);
- In **Rectangle** mode, you can select all grid elements contained in the rectangle he draws by a “drag and drop” action of the mouse on the map (cf. **Figure 23**);

- In **Polygon** mode, you can select all grid elements contained in the polygon you draw on the map by clicking several times on the polygon vertices. To finish the polygon, you have to click on the first point again (cf. **Figure 24**);
You can also edit the grid point with the copy and paste functions or the contextual menu that you have configured in the preferences (see 3.4).

The **Save grid points** button (cf. **Figure 25**) allows you to save in a file the selected grid points without modifying them. It works the same way as the **Edit grid points** button except that there is no **Single point** selection mode.

![Figure 25: Tool to save selected grid elements to file](image)

### 3.8. Editing river positions

Rivers can be drawn on the map as shown on **Figure 26**.

![Figure 26: Rivers drawn on the map](image)

The **Edit river position** button (cf. **Figure 27**) allows you to move the river positions on the grid. Simply drag the river positions. You will be asked if you want to update the river file.
3.9. Viewing the grid in 3D

On supported platforms, you can view the grid in three dimensions. Simply go to the **Tools>3D View** menu once you have loaded a map to display the 3D window shown on Figure 28. You can then move the map with the mouse left and right buttons and zoom in or out with the mouse wheel.

You can set the depth scale with the provided slider, choose the display mode, reset the view or save it as a PNG image.

Beware that if the land value of your grid is set to a very low value (say -999 999 meters), the 3D view will not provide a pertinent result. Moreover, be aware that for large grids (more than 1000x1000 grid elements), the rendering may be long and require a lot of memory.

![3D View of the Grid](image)

**Figure 28: 3D view of the grid**

3.10. Undoing an action

The user can undo some of the actions he performed. To do so, the user has to go in the **History** menu (cf. Figure 29) and select the last undoable action.
**Figure 29: History menu**
Annex A  Bathymetric grid file

A bathymetric grid file is a NetCDF file, which name ends with the .nc extension. The file has to follow the NetCDF format below:

```c
// dimensions:
ni = xxx ;
jn = xxx ;
// variables:
float H0(nj, ni) ;
H0:long_name = "bathymetric par rapport a REF_ZERO" ;
H0:units = "m" ;
H0:standard_name = "sea_floor_depth_below_REF_ZERO" ;
H0:standard_name = "sea_floor_depth_below_sea_level" ;
H0:FillValue = xxx ;
H0:valid_min = xxx ;
H0:valid_max = xxx ;
H0:coordinates = "longitude latitude"
float HX(nj, ni) ;
HX:long_name = "bathymetric hx par rapport a REF_ZERO" ;
HX:units = "m" ;
HX:standard_name = "sea_floor_depth_below_REF_ZERO" ;
HX:standard_name = "sea_floor_depth_below_sea_level" ;
HX:FillValue = xxx ;
HX:valid_min = xxx ;
HX:valid_max = xxx ;
HX:coordinates = "longitude_U latitude"
float HY(nj, ni) ;
HY:long_name = "bathymetric hy par rapport a REF_ZERO" ;
HY:units = "m" ;
HY:standard_name = "sea_floor_depth_below_REF_ZERO" ;
HY:standard_name = "sea_floor_depth_below_sea_level" ;
HY:FillValue = xxx ;
HY:valid_min = xxx ;
HY:valid_max = xxx ;
HY:coordinates = "longitude latitude_V"
float niv_moy(nj, ni) ;
niv_moy:long_name = "niveau moyen" ;
niv_moy:units = "m" ;
niv_moy:standard_name = "??" ;
niv_moy:FillValue = xxx ;
niv_moy:valid_min = xxx ;
niv_moy:valid_max = xxx ;
niv_moy:coordinates = "longitude latitude"
float ni(ni) ;
ni:long_name = "x-coordinate" ;
ni:axis = "X" ;
float nj(nj) ;
jn:long_name = "y-coordinate" ;
jn:axis = "Y" ;
double longitude(nj,nj) ;
lon:long_name = "longitude" ;
lon:standard_name = "longitude" ;
lon:units = "degree_east" ;
lon:valid_min = xxx ;
lon:valid_max = xxx ;
lon:FillValue = xxx ;
double latitude(nj,nj) ;
lati:long_name = "latitude" ;
lati:standard_name = "latitude" ;
lati:units = "degree_north" ;
lati:valid_min = xxx ;
lati:valid_max = xxx ;
lati:FillValue = xxx ;
double longitude_U(nj,nj) ;
lon:long_name = "longitude of U-points" ;
lon:standard_name = "longitude" ;
lon:units = "degree_east" ;
lon:valid_min = xxx ;
```

This document is the property of Artenum. It cannot be used, copied or distributed without prior written approval.
lon:valid_max = xxx ;
lon:_FillValue = xxx ;

double latitude_U(nj,ni) ;
lat:long_name = "latitude of U-points" ;
lat:standard_name = "latitude" ;
lat:units = "degree_north" ;
lat:valid_min = xxx ;
lat:valid_max = xxx ;
lat:_FillValue = xxx ;

double longitude_V(nj,ni) ;
lon:long_name = "longitude of V-points" ;
lon:standard_name = "longitude" ;
lon:units = "degree_east" ;
lon:valid_min = xxx ;
lon:valid_max = xxx ;
lon:_FillValue = xxx ;

double latitude_V(nj,ni) ;
lat:long_name = "latitude of V-points" ;
lat:standard_name = "latitude" ;
lat:units = "degree_north" ;
lat:valid_min = xxx ;
lat:valid_max = xxx ;
lat:_FillValue = xxx ;

double longitude_F(nj,ni) ;
lon:long_name = "longitude of F-points" ;
lon:standard_name = "longitude" ;
lon:units = "degree_east" ;
lon:valid_min = xxx ;
lon:valid_max = xxx ;
lon:_FillValue = xxx ;

double latitude_F(nj,ni) ;
lat:long_name = "latitude of F-points" ;
lat:standard_name = "latitude" ;
lat:units = "degree_north" ;
lat:valid_min = xxx ;
lat:valid_max = xxx ;
lat:_FillValue = xxx ;

// global attributes:
:geodetic_system = "GEO_SYS_WKT_FORMAT" ;
:geodetic_system_short = "GEO_SYS" ;
:grid_creation_mode = "GEOGRAPHIC_COORDINATES" ;
data_type = "OCO oriented grid" ;
:format_version = "1.2" ;
:Conventions = "CF-1.3" ;
:netcdf_version = "3.6.3" ;
:product_version = "1.0" ;
:software_version = "X.X" ;
:references = "http://www.previmer.org/" ;
:easting = "longitude" ;
northing = "latitude" ;
:grid_projection = "PROJECTION_SYSTEM_WKT_FORMAT" ;
:grid_projection_short = "n/a" ;
nstitution = "IFREMER" ;
:institution_references = "http://www.ifremer.fr/" ;
:contact = "info@previmer.org" ;
title = "bathymetry Golfe du Lion" ;
:product_name = "/export/home10/res/bathy_gdl.nc" ;
:creation_date = "2008-10-24T22:34:32Z" ;
:comment = "Arakawa C grid" ;
:source = "CREANAILLE V6.26" ;
:area = "GOLFE DU LION" ;
southernmost_latitude = "XX.XXXX" ;
northernmost_latitude = "XX.XXXX" ;
:latitude_resolution = "X.XXX" ;

:projected_latitude_resolution = "XXXXX.X" ; (il s'agit du dPhi)
westernmost_longitude = "-X.XXXX" ;
:easternmost_longitude = "X.XXXX" ;
:longitude_resolution = "X.XXX" ; (il s'agit du dX)
:projected_longitude_resolution = "XXXXX.X" ; (il s'agit du dX)
minimum_altitude = "0.0 m" ;
maximum_altitude = "0.0 m" ;
:altitude_resolution = "n/a" ;
:field_type = "permanent" ;
:distribution_statement = "Approved for public release. Distribution unlimited"
;
:operational_status = "operational" ;
:quality_index = "1" ;
:rotation_angle = "XX" ;
:latitude_rotation_center = "XX.XXXX" ;
:longitude_rotation_center = "XX.XXXX" ;
Annex B  Coastline file .line

The coastline file is an ASCII file which name ends with the .line extension. It contains the definition of the coastlines, the isobaths, the reefs and fringing reefs.

The file starts with a two lines header:

- The first line is composed of four spaces separated floats defining the geographical boundaries of the area described by the file: longitude_min longitude_max latitude_min latitude_max.
- The second line is composed of a string and an integer indicating respectively the geodetic reference system and the number of coastlines, isobaths and/or reefs: geodetic_system_name polylines_number.

The body of the file is then composed of blocks. There are as many blocks as polylines number.

Each block starts with a one-line header indicating the number of points composing the polyline and a code describing the line type. The code is an number taking the following values:

- 0 for coastlines
- Any positive value for isobaths
- A negative value (-1 or -2) for reefs

[line sample file]:

```
 165.33000000 167.50000000 -23.10000000 -21.41000000  WGS84  9
 16.50180000 -22.49082000
 16.47880000 -22.50999000
 16.47970000 -22.51010000
 16.48050000 -22.51051000
 16.48120000 -22.51100000
 16.48190000 -22.51141000
 16.48270000 -22.51155000
 16.48340000 -22.51152000
 16.48410000 -22.51137000
 16.48490000 -22.51107000
 16.48570000 -22.51067000
 16.48660000 -22.50985000
 16.48700000 -22.50921000
 16.48720000 -22.50843000
 16.48740000 -22.50751000
 16.48750000 -22.50663000
 14  40
 16.43440000 -22.49340000
 16.43500000 -22.49416000
 16.43560000 -22.49497000
 16.43620000 -22.49562000
 16.43690000 -22.49644000
 16.43750000 -22.49734000
 16.43790000 -22.49813000
 16.43820000 -22.49858000
 16.43890000 -22.49874000
 16.43960000 -22.49858000
 16.44060000 -22.49823000
 16.44140000 -22.49783000
 16.44230000 -22.49744000
 16.44320000 -22.49701000
 22  30
 16.57450000 -22.38101000
 16.57490000 -22.38060000
```

Reference: IFR_BMGV3_D1B_Check_User_Manual
Version: 3
Revision: 0
Status: Final
Date: 16/12/2010
Fortran writing procedure:

```
! ecriture en-tete
write(24,110) lon_min , lon_max , lat_min , lat_max
write(24,111) sys_geo , nb_lines
!
do i=1,nb_lines
! ecriture en-tete ligne
write(24,112) nb_points, code

do j = 1, nb_points
! ecriture points
write(24,113), lon(j), lat(j)
end do
enddo
```

```
110 format(f13.8,1x,f13.8,1x,f13.8,1x,f13.8)
111 format(a10,x,i8)
112 format(i8,i8)
113 format(f13.8,1x,f13.8)
```
Annex C  Soundings file .sdg

The soundings file is an ASCII file, which name ends with the .sdg extension.

The file starts with a two lines header:

- The first line is composed of four spaces separated floats defining the geographical boundaries of the area described by the file: \textit{longitude\_min longitude\_max latitude\_min latitude\_max}

- The second line is composed of two strings and an integer indicating respectively the geodetic reference system, the name of the reference zero and the number of soundings: \textit{geodetic\_system\_name reference\_zero soundings\_number}.

The body of the file is then composed of one line per sounding.

Each line is composed of three space-separated floats: the longitude, the latitude and the depth of the sounding.

\textit{.sdg sample file:}

<table>
<thead>
<tr>
<th>Longitude</th>
<th>Latitude</th>
<th>Depth</th>
</tr>
</thead>
<tbody>
<tr>
<td>4.62068990</td>
<td>5.82059000</td>
<td>43.07000000</td>
</tr>
<tr>
<td>WGS84 zero_hydro_SHOM 87</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4.81269600</td>
<td>43.34508100</td>
<td>-20.00</td>
</tr>
<tr>
<td>4.79527620</td>
<td>43.34925800</td>
<td>-20.00</td>
</tr>
<tr>
<td>4.77729080</td>
<td>43.35133000</td>
<td>-20.00</td>
</tr>
<tr>
<td>4.75970410</td>
<td>43.35668900</td>
<td>-20.00</td>
</tr>
<tr>
<td>4.77084110</td>
<td>43.35287800</td>
<td>13.60</td>
</tr>
<tr>
<td>4.75753500</td>
<td>43.34952200</td>
<td>0.80</td>
</tr>
<tr>
<td>4.77102280</td>
<td>43.34605000</td>
<td>2.90</td>
</tr>
<tr>
<td>4.76595780</td>
<td>43.34127000</td>
<td>8.60</td>
</tr>
<tr>
<td>4.78191180</td>
<td>43.34064100</td>
<td>8.00</td>
</tr>
<tr>
<td>4.79313900</td>
<td>43.34381900</td>
<td>0.80</td>
</tr>
<tr>
<td>4.80268480</td>
<td>43.34013900</td>
<td>4.60</td>
</tr>
<tr>
<td>4.81545310</td>
<td>43.33760100</td>
<td>0.30</td>
</tr>
<tr>
<td>4.86357500</td>
<td>43.33628800</td>
<td>1.20</td>
</tr>
<tr>
<td>4.86536980</td>
<td>43.33961100</td>
<td>1.40</td>
</tr>
<tr>
<td>4.87438110</td>
<td>43.34523000</td>
<td>1.60</td>
</tr>
<tr>
<td>4.89195500</td>
<td>43.35672000</td>
<td>1.80</td>
</tr>
<tr>
<td>4.90652890</td>
<td>43.36531800</td>
<td>3.70</td>
</tr>
<tr>
<td>4.91444780</td>
<td>43.37419100</td>
<td>0.90</td>
</tr>
<tr>
<td>4.90920780</td>
<td>43.38016100</td>
<td>0.60</td>
</tr>
<tr>
<td>4.90579890</td>
<td>43.37603000</td>
<td>0.40</td>
</tr>
<tr>
<td>4.90129420</td>
<td>43.37309900</td>
<td>0.50</td>
</tr>
<tr>
<td>4.89121200</td>
<td>43.37009800</td>
<td>0.40</td>
</tr>
<tr>
<td>4.89323620</td>
<td>43.37503100</td>
<td>4.20</td>
</tr>
<tr>
<td>4.88531400</td>
<td>43.36904100</td>
<td>0.80</td>
</tr>
<tr>
<td>4.88077400</td>
<td>43.37495000</td>
<td>0.80</td>
</tr>
<tr>
<td>4.88747220</td>
<td>43.36867100</td>
<td>-10.00</td>
</tr>
<tr>
<td>4.88508180</td>
<td>43.36854900</td>
<td>-10.00</td>
</tr>
<tr>
<td>4.88330220</td>
<td>43.36829000</td>
<td>-10.00</td>
</tr>
<tr>
<td>4.88501410</td>
<td>43.36819400</td>
<td>-10.00</td>
</tr>
<tr>
<td>4.88659720</td>
<td>43.36816000</td>
<td>-10.00</td>
</tr>
<tr>
<td>4.87097120</td>
<td>43.37591200</td>
<td>0.10</td>
</tr>
<tr>
<td>4.86599300</td>
<td>43.38219100</td>
<td>0.90</td>
</tr>
<tr>
<td>4.86467600</td>
<td>43.38473100</td>
<td>0.60</td>
</tr>
<tr>
<td>4.85770890</td>
<td>43.38122200</td>
<td>0.30</td>
</tr>
<tr>
<td>4.86467600</td>
<td>43.38668000</td>
<td>2.70</td>
</tr>
<tr>
<td>4.87171890</td>
<td>43.38975900</td>
<td>3.50</td>
</tr>
<tr>
<td>4.87121580</td>
<td>43.38605900</td>
<td>3.40</td>
</tr>
<tr>
<td>4.90419580</td>
<td>43.38296100</td>
<td>9.00</td>
</tr>
<tr>
<td>4.89022220</td>
<td>43.37725800</td>
<td>5.80</td>
</tr>
<tr>
<td>4.89316420</td>
<td>43.37516000</td>
<td>4.20</td>
</tr>
<tr>
<td>4.89590120</td>
<td>43.38473100</td>
<td>9.10</td>
</tr>
<tr>
<td>4.88973190</td>
<td>43.37789200</td>
<td>6.60</td>
</tr>
<tr>
<td>4.88734010</td>
<td>43.38335000</td>
<td>6.80</td>
</tr>
</tbody>
</table>
Fortran writing procedure:

```
! Ouverture fichier .sdg
open(24,file='RHOM.sdg',form='formatted')

! ecriture en-tete
write(24,104)lon_min,lon_max,lat_min,lat_max
write(24,105)sys_geo,zero_ref,nb_sondes

! Ecriture sondes
do i = 1, nb_sondes
  write(24,106),lon(i),lat(i),sonde(i)
end do

! fermeture fichier .sdg
close(24)
```

104 format(f13.8,1x,f13.8,1x,f13.8,1x,f13.8)
105 format(a10,x,a15,i8)
106 format(f13.8,1x,f13.8,1x,f10.2)
Annex D Rivers file .river

The rivers file is an ASCII file, which name ends with the .river extension.

Each line is composed of an integer representing the index i of the river position in the grid, an integer representing the index j of the river position in the grid and the grid name.

.river sample file:

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>290</td>
<td>90</td>
<td>River 3</td>
</tr>
<tr>
<td>10</td>
<td>10</td>
<td>River 2</td>
</tr>
<tr>
<td>57</td>
<td>69</td>
<td>River 1</td>
</tr>
</tbody>
</table>

Fortran format:

format(i5, 1x, i5, a20)
Annex E Colour bar file format

The colour bar file is a XML file describing a colour gradient.

The root element is the `<Gradient>` element. It contains three mandatory attributes: startColor, endColor and nbColors. The two first ones represent the gradient starting and ending colours (expressed using their hexadecimal code), the last one is the number of colours composing the gradient.

Then, there are as many `<Color>` elements as required, each one describing the colour position index and value (in hexadecimal code). The index positions in the gradient start at 0 and end at nbColors – 1. However, these two extreme positions are reserved for the startColor and the endColor.

Example of colour gradient file:

```xml
<?xml version="1.0" encoding="UTF-8"?>
<Gradient startColor="#ff0000" endColor="#0000ff" nbColors="50">
  <Color position="37" code="#00ffff"/>
  <Color position="25" code="#00ff00"/>
  <Color position="12" code="#ffff00"/>
</Gradient>
```